Welcome
Welcome to goprouser

You are currently viewing our boards as a guest, which gives you full access to view most discussions and access.. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements if any. Registration is fast, simple, and absolutely free, so please, join our community today! Any issues email [email protected]

Doesn't turn on

Discuss the GoPro Hero 5Mp & HD 960 in General, Issues and Trouble Shooting

Doesn't turn on

Postby cycloscope » Wed Mar 26, 2014 1:41 am

Hi Action people!
I've a problem with my hero 1. It doesn't turn on. When in charge i see the red light but, also fully charged, there's no way to turn it on. I've triyed several tricks found on the web (remove battery and insert again things) but nothing seems to work. Do you have any advice? Could be the battery?
If somebody is in Bologna (italy) zone: could we meet to try your battery on my cam to see if the problem is there?

Thanks!
cycloscope
 
Posts: 1
Joined: Wed Mar 26, 2014 12:56 am

Re: Doesn't turn on

Postby R GoPro » Wed Mar 26, 2014 1:55 am

Measure the battery voltage with a Volt meter.
User avatar
R GoPro
 
Posts: 175
Joined: Fri Mar 22, 2013 6:52 am
Location: Minnesota


Return to GoPro Hero 5MP & HD Hero 960

Who is online

Users browsing this forum: No registered users and 0 guests

suspicion-preferred